ASUS G74SX BACKLIT KEYBOARD DRIVER DOWNLOAD

Thanks, in advance, for you help, Sir Robin. Thanks for the feedback dstrakele! Do the keyboard lights flash briefly at boot, or is that not functioning either? Results 1 to 10 of I thought this was all explained in the first post?

Uploader: Yokus
Date Added: 15 July 2011
File Size: 31.17 Mb
Operating Systems: Windows NT/2000/XP/2003/2003/7/8/10 MacOS 10/X
Downloads: 60111
Price: Free* [*Free Regsitration Required]

Last edited by C4RN1; at You must log in or sign up to reply here. The reason was a stub for backlight.

ASUS ROG GLVW – backlit keyboard not working [Solved] – Laptop Tech Support

The G74SX appears to be subject to the same problem as the G73 series. This is still helpful in for a laptop. Have you tried any software fixes? After reading the tutorial on how to flash your bios using easyflash you can proceed to download the file below.

I’m not exactly sure when it happened. So far, nothing has produced a change in behavior. Last edited by jamcghie; at Learn how to read technet to avoid major deployment issues MavsVj February 2, 8: Thanks for the feedback dstrakele!

Last Drivers  SITECOM MIMO XR WL 151 DRIVER

Long story short, one of the many issues I ran into was that the keyboard backlight asu flash upon post. Unintsall the current ATK driver first. Hope you understand now!

g74sx backlight keyboard.

Here is how I fixed the problem: Alternatively, you could try to reflash the BIOS or check the keyboard light cable connection. Best regards, Sam, from Malaysia. Try re-installing it, if you have it already. Make sure you know what you’re doing.

G74SX Keyboard backlight disabled

I had a similar issue: It’s keyboadr thank you man. Sometime recently, the keyboard backlight on my G74SX stopped working. Backlit worked before I sent in the computer, now it doesn’t. Turn the laptop upside-down.

Originally Posted by BrodyBoy. Your question Keyhoard the answer. Sir RobinApr 28, Cloudy1 February 1, 5: Try reinstalling the driver first and see if it helps.

ApostateTapir Dec 28, at 8: I researched this for about 3 or 4 hours and finally stumbled upon a post back in that had a bad link because the webpage had been deleted.

Last Drivers  EPSON AL-C1100 DRIVER

Now check if you’ve found your fix.

The only thing I’ve done recently, is remove bloatware, so it may have something to do with deleting Asus applications.